您的位置:首页 > 其它

POJ 3009 Curling 2.0 (DFS)

2014-08-04 15:41 453 查看
Curling 2.0
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11412Accepted: 4827
Description

On Planet MM-21, after their Olympic games this year, Curling 2.0curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only
a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone
begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:

The stone hits a block (Fig. 2(b), (c)).

The stone stops at the square next to the block it hit.
The block disappears.

The stone gets out of the board.

The game ends in failure.

The stone reaches the goal square.

The stone stops there and the game ends in success.

You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed
as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board

First row of the board

...

h-th row of the board

The width and the height of the board satisfy: 2 <=w <= 20, 1 <=h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6

1 0 0 2 1 0

1 1 0 0 0 0

0 0 0 0 0 3

0 0 0 0 0 0

1 0 0 0 0 1

0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other
than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output
1
4
-1
4
10
-1

Source
Japan 2006 Domestic

题目链接 :http://poj.org/problem?id=3009

题目大意 :丢石头遇到障碍物停在障碍物的前一个格子中且障碍物消失,丢的条件是周围有一格为空,问从起点到终点最少丢多少次

题目分析 :DFS条件注意下就行,这题我wa了十几次,查错查了两个多小时,出题人给的数据虽然多,但是巧妙的隐藏了行列输反的wa点(可能细心的读者不会犯本笔者的智障问题),一般都是先输入行在输入列,这题是要先输入列再输入行,而且它给的数据不是n*n的就是n*1的,所以尽管行列反了,样例依旧可以轻松过掉,真是坑爹啊!!

在这里附上两组数据:6 2

2 0 1 1 1 1

1 1 1 1 1 3 输出: -1

6 2

2 0 1 1 0 1

1 1 1 1 3 1 输出: 4

#include <cstdio>
#include <cstring>
int dirx[4] = {0,-1,0,1};  //四个方向
int diry[4] = {-1,0,1,0};
int map[22][22];
int m, n;
int ans;

void DFS(int x, int y, int step)  //深度优先搜索算法
{
    if(step > 10)  //步数大于10返回
        return;
    for(int i = 0; i < 4; i++)   //枚举各个方向
    {
        int xx = x + dirx[i];   
        int yy = y + diry[i];
        //判断是否出界,当前步数是否小于之前的步数,当前位置是否非法(必须有空格才能扔)
        if(step < ans && xx > 0 && xx <= m && yy > 0 && yy <= n && map[xx][yy] != 1)
        {
            //当没有出界且格子为空时,一直沿着当前方向走
            while(xx > 0 && xx <= m && yy > 0 && yy <= n && map[xx][yy] == 0)
            {
                xx += dirx[i];
                yy += diry[i];
            }
            //记录界外或者障碍物的前一步
            int xx2 = xx - dirx[i];
            int yy2 = yy - diry[i];
            //如果出界则回到for换方向
            //如果在界内且落在在终点将步数加1(因为从0开始的),这里不return,因为求最小要全部遍历完
            //如果在界内且落在障碍物上,对障碍物前一步继续进行深搜,此时将障碍物设为0(障碍物被清除)
            //DFS完还要将其设回为1,因为要遍历所有的情况.
            if(xx > 0 && xx <= m && yy > 0 && yy <= n)
            {
                if(map[xx][yy] == 3)
                    ans = step + 1;
                if(map[xx][yy] == 1)
                {
                    map[xx][yy] = 0;
                    DFS(xx2, yy2, step + 1);
                    map[xx][yy] = 1;
                }
            }
        }
    }
}

int main()
{
    int sx, sy;     //记录起点和终点的坐标
    while(scanf("%d %d", &n, &m) != EOF && (m + n))
    {
        ans = 11;
        for(int i = 1; i <= m; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j] == 2)
                {
                    map[i][j] = 0;   //找到起点记录下后将其值设为0
                    sx = i;
                    sy = j;
                }
            }
        }
        DFS(sx,sy,0);   //起点步数为0
        if(ans < 11)
            printf("%d\n",ans);
        else
            printf("-1\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: