您的位置:首页 > 其它

杭电acm1014 hdu-acm-1014解题报告

2014-08-04 15:34 513 查看
原题地址链接:
点击打开原题链接

原题内容:


Uniform Generator

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17247 Accepted Submission(s): 6753



Problem Description

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully
can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function.
Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice"
message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program
should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999


Sample Output

3         5    Good Choice

15        20    Bad Choice

63923     99999    Good Choice


题意解释:
本题比较容易,就是输入两个数字,看看公倍数是不是只有1,如果是,就输出Good Choice;不是输出Bad Choice;输出格式不好把握,那就直接复制粘贴,然后把数字改成你%d;不知道的右对齐多少位的话,复制过来一个一个删除,删了10下,应该是10位;所以%10d;
代码如下:
#include<stdio.h>
int gb(int a,int b)
{
return !b?a:gb(b,a%b);
}
main()
{
int a,b;
while(~scanf("%d%d",&a,&b))
{
printf("%10d%10d",a,b);
if(gb(a,b)==1)
printf("    Good Choice\n\n");
else
printf("    Bad Choice\n\n");
}
}


运行结果截图:


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: