您的位置:首页 > 其它

poj 2406 Power Strings(kmp算法)

2014-08-04 14:56 483 查看
题目链接:http://poj.org/problem?id=2406

Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 31957Accepted: 13322
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source

Waterloo local 2002.07.01
[Submit] [Go Back] [Status]
[Discuss]


Home Page

Go
Back

To top

这道题其实是考KMP中fail数组的运用。题意要求一个字符串中循环节的个数。

对于字符串 pat ,若fail[j]=k 则 pat[0..k]=pat[j-k,j]如果总长度是这个循环节长度的整数倍,那么循环节的个数就是这个倍数。反之,说明这个字符串并不是在不停地循环,而是在某些位置加入了一个或几个不"和谐"的字符,导致指针无法回溯到第一个循环节之后,这样,输出1就可以了。

详细的可以瞧瞧这个博客http://www.cnblogs.com/coredux/archive/2012/08/13/2635987.html

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<map>
#include<set>
#include<vector>
#include<string>
#include<stack>
#include<queue>
#include<bitset>
using namespace std;
#define CLR  memset(A,0,sizeof(A))
const int MAX=1000005;
int fail[MAX];
char str[MAX];
int kmp(char *pat){
int len=strlen(pat);
memset(fail,-1,sizeof(fail));
for(int i=1;pat[i];i++){
int k;
for(k=fail[i-1];k>=0&&pat[i]!=pat[k+1];k=fail[k]);
if(pat[k+1]==pat[i]){
fail[i]=k+1;
}
}
//  for(int i=0;i<=len;i++) cout<<fail[i]<<endl;
int t=len-1-fail[len-1];
if(len%t==0) return len/t;
return 1;
}
int main(){
while(~scanf("%s",str)&&str[0]!='.'){
cout<<kmp(str)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: