您的位置:首页 > 编程语言 > C语言/C++

C++结构体之统计最高最低分

2014-08-04 11:42 204 查看
/*
*Copyright (c) 2014 ,烟台大学计算机学院
*All rights reserved.
*作者:张凤宁
*完成日期:2014年8月4
*版本号:v1.0
*问题描述:
*样例输入:
*样例输出:
*问题分析:用简单的方法,学会活学活用
*/
#include <iostream>
using namespace std;
struct Student
{
char name[20];
double score;
};
int main()
{
Student stu[5];
Student a;
for(int i=0; i<5; i++)
{
cin>>stu[i].name>>stu[i].score;
}
for(int j=0; j<4; j++)
{
for(int k=0; k<4-j; k++)
{
if(stu[k].score>stu[k+1].score)
{
a=stu[k];
stu[k]=stu[k+1];
stu[k+1]=a;
}
}
}
cout<<"MAX:  "<<stu[4].name<<"  "<<stu[4].score<<endl;
cout<<endl;
cout<<"MIN:"<<stu[0].name<<" "<<stu[0].score<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: