您的位置:首页 > 其它

poj3262 Protecting the Flowers(贪心)

2014-08-04 09:39 323 查看
Protecting the Flowers

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 4232Accepted: 1709
Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent
damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroysDi (1 ≤Di ≤ 100) flowers
per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cowi to its barn requires 2 ×Ti minutes (Ti to get there andTi to return). FJ starts
at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input
Line 1: A single integer N

Lines 2..N+1: Each line contains two space-separated integers, Ti andDi, that describe a single cow's characteristics
Output
Line 1: A single integer that is the minimum number of destroyed flowers
Sample Input
6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output
86

Hint
FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses
16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.
/*题目大意:有n头牛,每个牛给一个在草坪上呆的时间t和每个单位时间内的伤害,农夫每次只能牵走一头牛,时间是2t;求对花朵造成的最小伤害。
思路:按每头牛的单位伤害所需的时间排序因为在相同时间内,可将一个牛用t/n分解成t/n个牛来看待,每次一定是将最大伤害的牵走注意得用long long 型
心得:贪心,自己知道了贪心还写不出来,哎,真挫。。*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAX=100000+10;
struct Cow
{
   long long  t,d;    
}c[MAX];
bool cmp(Cow a,Cow b)
{
return  a.t*b.d-b.t*a.d<0; //按单位伤害所需的时间排序   
}
int main()
{
    int N;
    
    while(scanf("%d",&N)!=EOF)
    {
   	 long long sumd=0;
     for(int i=1;i<=N;i++)
     {
     scanf("%lld%lld",&c[i].t,&c[i].d);
     sumd+=c[i].d;
     }
     long long ans=0;
     sort(c+1,c+N+1,cmp);
     for(int i=1;i<=N;i++)
     {
	  	sumd-=c[i].d;
		ans+=sumd*c[i].t*2; 
	 }
	 printf("%lld\n",ans);
    }
return 0;    
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: