您的位置:首页 > 其它

hdu-oj 1061 Rightmost Digit

2014-08-03 22:30 441 查看

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31706    Accepted Submission(s): 12130

[align=left]Problem Description[/align]
Given a positive integer N, you should output the most right digit of N^N.
[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).
[align=left]Output[/align]
For each test case, you should output the rightmost digit of N^N.
[align=left]Sample Input[/align]

2
3
4

[align=left]Sample Output[/align]

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6题目大意:输出N^N.的个位数字解题思路: 20一个周期有规律附代码:
#include<iostream>
using namespace std;
int main()
{
int  rdigit[20] = {0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9};
int n;
cin>>n;
while(n--)
{
int temp;
cin>>temp;
cout<<rdigit[temp%20]<<endl;
}

return 0;
}
计算机找规律代码:
#include<stdio.h>
int main()
{
long int n;
int i,a[100],j,t,y;
scanf("%d",&t);
for(i=0;i<t;i++)
{
scanf("%d",&n);
y=n%10;a[0]=y;
for(j=1;;j++)//找规律周期
{
a[j]=a[j-1]*y;
if(a[j]%10==y)
break;
}
n=n%j;
if(n==0)
n=n+j;
a[n-1]=a[n-1]%10;
printf("%d\n",a[n-1]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: