您的位置:首页 > 产品设计 > UI/UE

hdu 2604 queuing dfa dp + 矩阵快速幂

2014-08-03 22:15 405 查看



Queuing

[b]Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2602 Accepted Submission(s): 1215



Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.



Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue
else it is a E-queue.

Your task is to calculate the number of E-queues mod M with length L by writing a program.



Input

Input a length L (0 <= L <= 10 6) and M.



Output

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.



Sample Input

3 8
4 7
4 8




Sample Output

6
2
1




Author

WhereIsHeroFrom



Source

HDU 1st “Vegetable-Birds
Cup” Programming Open Contest



Recommend

lcy | We have carefully selected several similar problems for you: 1588 1757 2606 2276 2603


参考:http://www.xuebuyuan.com/1573860.html[/b] http://hi.baidu.com/aekdycoin/item/f3a474a7ee3b0d218919d3ae

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 4;
int M;
int f[6] = {9,6,4,2,0};
struct Matrix{
    int v

;
    Matrix(){ memset(v,0,sizeof(v));}
    Matrix(int){
                memset(v,0,sizeof(v));
                v[0][0] =
                v[0][1] =
                v[1][2] =
                v[2][0] =
                v[2][3] =
                v[3][0] = 1;}
};
Matrix operator *(Matrix a,Matrix b){
    Matrix c;
    for(int i = 0; i < N; ++i)
        for(int j = 0; j < N; ++j)
            for(int k = 0; k < N; ++k){
                c.v[i][j] += a.v[i][k] * b.v[k][j] ;
                if(c.v[i][j] >= M) c.v[i][j] %= M;
            }
    return c;
}
Matrix operator %(Matrix a,int m){
        for(int i = 0; i < N; ++i)
            for(int j = 0;j < N; ++j)
                a.v[i][j] %= m;
        return a;
}

Matrix operator ^(Matrix a,int b){
        if(b == 1) return a;
        Matrix c = (a^(b>>1));
        if(b&1)
        return  (c*c%M)*a % M;
        return  c*c % M;
}
Matrix t(0);
void solve(int n){
    Matrix ans;
    if(n <= 4){
        printf("%d\n",f[4 - n] % M);return;
    }
    ans = t^(n - 4);
    int res = 0;
	for(int i = 0;i < 4; i++)
		res=(res + (f[i] * ans.v[i][0])% M ) % M;
    printf("%d\n",res);
}

int main()
{

    int n;
    while(~scanf("%d%d",&n,&M)){
        solve(n);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: