您的位置:首页 > 其它

POJ-1969-Count on Canton

2014-08-03 21:17 465 查看
Count on Canton

Description

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

1/1 1/2 1/3 1/4 1/5 ...

2/1 2/2 2/3 2/4

3/1 3/2 3/3

4/1 4/2

5/1


In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.
Input

The input list contains a single number per line and will be terminated by endof-file.
Output

You are to write a program that will read a list of numbers in the range from 1 to 10^7 and will print for each number the corresponding term in Cantor's enumeration as given below.
Sample Input
3
14
7

Sample Output
TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4


这题是个找规律的题,通过题目给的提示 我们可以发现 是通过类似于s型的路线来查找的,最重要的规律是:斜着数第i行有i个数,而且偶数行是从上往下数的,初始分母是i且递减,分子式1且递增;而奇数行正好相反。。。这就是规律。。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

using namespace std;

int main()
{
    int n,i,s,t,x;
    float num;
    while (~scanf ("%d",&n))
    {
        s = 0;
        t = 1;
        x = 0;
        for (i = 1;; i++)
        {
            s += i;
            if (s >= n)
            {
                x = s - n ;
                break;
            }
            t++;
        }

       // printf ("%d %d\n",t,t - x);//第几行第几个
        if (t % 2 == 1)
        {
           printf ("TERM %d IS %d/%d\n",n,x+1,t-x);
        }
        else
        {
            printf ("TERM %d IS %d/%d\n",n,t-x,x+1);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: