您的位置:首页 > 理论基础 > 数据结构算法

POJ 1703 Find them, Catch them(数据结构-并查集)

2014-08-03 15:21 337 查看
Find them, Catch them
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

题目大意:

T组测试数据,n个人,m组询问,2个帮派,D a b 表示 a,b 不在同一帮派 ,A a b表示查询a和b的关系。

解题思路:

并查集。将每个人对应两个节点,分属于两个帮派。1~n表示帮派1中的,n+1~2n表示帮派2中的。若知道a和b不是同一帮的,那么将a和b+n放到一个集合中,b和a+n放到一个集合中。并查集查询a和b的关系时,如果a与b+n在一个集合中,则说明他们不在同一帮;若a和b在同一集合,则在同一帮;否则说明他们关系不确定。连线时交叉连,即保证间隔两人在同一集合。即敌人的敌人是朋友。

参考代码:

#include <cstdio>
using namespace std;

const int MAXN = 200010;
int N, M, nCase, father[MAXN], rank[MAXN];

int find_set(int x) {
return father[x] = father[x] == x ? x : find_set(father[x]);
}

void union_set(int x, int y) {
int a = find_set(x), b = find_set(y);
if (rank[a] < rank[b]) {
father[a] = b;
} else {
father[b] = a;
if (rank[a] == rank[b]) {
rank[a]++;
}
}
}

void init() {
for (int i = 1; i <= 2*N; i++) {
father[i] = i;
rank[i] = 1;
}
}

void solve() {
for (int i = 0; i < M; i++) {
char op;
int a, b;
getchar();
scanf("%c%d%d", &op, &a, &b);
if (op == 'D') {
union_set(a, b+N);
union_set(b, a+N);
} else if (op == 'A') {
if (find_set(a) == find_set(b+N)) {
printf("In different gangs.\n");
} else if (find_set(a) == find_set(b)) {
printf("In the same gang.\n");
} else {
printf("Not sure yet.\n");
}
}
}
}

int main() {
scanf("%d", &nCase);
while (nCase--) {
scanf("%d%d", &N, &M);
init();
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 并查集