您的位置:首页 > 其它

hdu 4901 The Romantic Hero

2014-08-03 12:50 369 查看


The Romantic Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1078    Accepted Submission(s): 450


Problem Description

There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil.
Also, this devil is looking like a very cute Loli.

You may wonder why this country has such an interesting tradition? It has a very long story, but I won't tell you :).

Let us continue, the party princess's knight win the algorithm contest. When the devil hears about that, she decided to take some action.

But before that, there is another party arose recently, the 'MengMengDa' party, everyone in this party feel everything is 'MengMengDa' and acts like a 'MengMengDa' guy.

While they are very pleased about that, it brings many people in this kingdom troubles. So they decided to stop them.

Our hero z*p come again, actually he is very good at Algorithm contest, so he invites the leader of the 'MengMengda' party xiaod*o to compete in an algorithm contest.

As z*p is both handsome and talkative, he has many girl friends to deal with, on the contest day, he find he has 3 dating to complete and have no time to compete, so he let you to solve the problems for him.

And the easiest problem in this contest is like that:

There is n number a_1,a_2,...,a_n on the line. You can choose two set S(a_s1,a_s2,..,a_sk) and T(a_t1,a_t2,...,a_tm). Each element in S should be at the left of every element in T.(si < tj for all i,j). S and T shouldn't be empty.

And what we want is the bitwise XOR of each element in S is equal to the bitwise AND of each element in T.

How many ways are there to choose such two sets? You should output the result modulo 10^9+7.

 

Input

The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains a integers n.

The next line contains n integers a_1,a_2,...,a_n which are separated by a single space.

n<=10^3, 0 <= a_i <1024, T<=20.

 

Output

For each test case, output the result in one line.

 

Sample Input

2
3
1 2 3
4
1 2 3 3

 

Sample Output

1
4

 

Author

WJMZBMR

 

题解及代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int mod=1000000007;
typedef long long ll;
ll dp1[1004][2050];
ll dp2[1004][2050];
int c[1010];
void init()
{
memset(dp1,0,sizeof(dp1));
memset(dp2,0,sizeof(dp2));
}

int main()
{
int T,n,x;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
init();
int ma=-1,t;
for(int i=1;i<=n;i++)
{
scanf("%d",&c[i]);
ma=max(ma,c[i]);
if(i==n) break;
dp1[i][c[i]]++; //记得每输入一个数,就要记录一下
t=min(ma*2,2048);
for(int j=0;j<=t;j++)
{
dp1[i][j]=(dp1[i][j]+dp1[i-1][j]+dp1[i-1][j^c[i]])%mod;
//printf("i:%d j:%d %d\n",i,j,dp1[i][j]);
}
}
//printf("\n");
for(int i=n;i>=2;i--)
{
dp2[i][c[i]]++; //同上,记录
for(int j=0;j<=t;j++)
{
dp2[i][j]+=dp2[i+1][j];
dp2[i][j&c[i]]=(dp2[i][j&c[i]]+dp2[i+1][j])%mod;
}
}
/*for(int i=n;i>=2;i--)
{
for(int j=0;j<=t;j++)
{
printf("i:%d j:%d %d\n",i,j,dp2[i][j]);
}
}
puts("");
*/
ll ans=0;
for(int i=2;i<=n;i++)
{
for(int j=0;j<=t;j++)
{
if(dp1[i-1][j]&&dp2[i][j])
ans=(ans+dp1[i-1][j]*(dp2[i][j]-dp2[i+1][j]))%mod; //应为会出现重复的情况
//所以dp2[i][j]-dp2[i+1][j]
//保证每次相乘的都是新出现的结果
// printf("i:%d j:%d %d\n",i,j,ans);
}

}
printf("%I64d\n",ans);
}
return 0;
}

/*
题目意思是给出一串数序列,问是否能利用左侧的部分数进行异或,右侧的数进行与,来得到相等的数。

由于题目中给出的数最大为1024,所以最后总得到的结果最大也不超过2048,所以我们可以开出一个数组
来记录当我们进行到某个数时,我们能得到什么数,且它的数目是多少。

异或的操作从左向右进行,与的操作从右向左进行,最后对照相乘就行了。
这里给出两个dp的推导公式:
1.异或:dp2[i][j&c[i]]=(dp2[i][j&c[i]]+dp2[i+1][j])%mod;
2.与:dp2[i][j]+=dp2[i+1][j]; dp2[i][j&c[i]]=(dp2[i][j&c[i]]+dp2[i+1][j])%mod;

*转载请注明出处,谢谢。
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: