您的位置:首页 > 其它

HDU 1325 Is It A Tree?

2014-08-03 08:06 288 查看
Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.



Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist
of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.



Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).



Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1




Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.




Source
North Central North America 1997



树的判断,主要有三点

1:不能有环,

2:不能有两个独立的区间,为此我开了一个vis
,来标记出现的数字

3:一个点的入度不能大于1,意思就是 a->b c->b,那么b的入度就大于1了

注意的地方应该都说完了,上代码喽(⊙o⊙)…

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 1005

int father
,vis
,d
;
int n,m;

int cha(int x)
{
    if(x!=father[x])
        father[x]=cha(father[x]);
    return father[x];
}

int main()
{
    int i,a,b,ca=0;

    while(scanf("%d%d",&a,&b))
    {
        if(a<0&&b<0) break;

        if(a==0&&b==0)  //空树也是树
        {
            printf("Case %d is a tree.\n",++ca);
            continue;
        }

        for(i=0;i<N;i++)
        {
            father[i]=i;
            d[i]=0;
            vis[i]=0;
        }

         int flag=0;

       while(a+b)
       {
           vis[a]=vis[b]=1;

           int aa=cha(a);
           int bb=cha(b);

           if(aa==bb)
               flag=1;

           father[aa]=bb;
           d[b]++;
           scanf("%d%d",&a,&b);
       }

       if(flag)
       {
            printf("Case %d is not a tree.\n",++ca);
            continue;
       }
       else
       {
           int num=0;

           for(i=0;i<N;i++)
           {
               if(father[i]==i&&vis[i])  //num记录独立区间数(不能大于2)
                num++;

               if(d[i]>1)  flag=1; //单独点的入度不能大于2

               if(num>1)   flag=1;

               if(flag)    break;
           }

               if(flag)
                 printf("Case %d is not a tree.\n",++ca);
               else
                 printf("Case %d is a tree.\n",++ca);
       }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: