您的位置:首页 > 运维架构

BZOJ 1646: [Usaco2007 Open]Catch That Cow 抓住那只牛

2014-08-02 23:29 381 查看

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware
of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

    农夫约翰被通知,他的一只奶牛逃逸了!所以他决定,马上幽发,尽快把那只奶牛抓回来.
    他们都站在数轴上.约翰在N(O≤N≤100000)处,奶牛在K(O≤K≤100000)处.约翰有
两种办法移动,步行和瞬移:步行每秒种可以让约翰从z处走到x+l或x-l处;而瞬移则可让他在1秒内从x处消失,在2x处出现.然而那只逃逸的奶牛,悲剧地没有发现自己的处境多么糟糕,正站在那儿一动不动.
    那么,约翰需要多少时间抓住那只牛呢?

Input

* Line 1: Two space-separated integers: N and K

    仅有两个整数N和K.

Output

* Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

    最短的时间.

Sample Input

5 17

Farmer John starts at point 5 and the fugitive cow is at point 17.

Sample Output

4

OUTPUT DETAILS:

The fastest way for Farmer John to reach the fugitive cow is to

move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

题解

bfs即可。因为可以到x*2也可以往回走,但注意往回走只能一个一个走,所以bfs边界x<=n+k,因为,若x=2*n且x>n+k(n<k)则要往回走>n次才能到k,还不如一开始就往回走到k整除2的地方再一个两倍直接到k或k-1。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<algorithm>
#define inf 1<<30
using namespace std;
int n,m,t,w,x,b,a[200005],q[200005],mark[200005];
int main()
{
scanf("%d%d",&n,&m);
if(n==m) {printf("0\n"); return 0;}
for(int i=0;i<=n+m;i++) a[i]=inf;
t=0; w=1; q[0]=n; a
=0; mark
=1;
while(t!=w)
{x=q[t];
t=(t+1)%200005;
if(x-1>=0&&a[x-1]>a[x]+1)
{a[x-1]=a[x]+1;
if(!mark[x-1]) {q[w]=x-1; mark[x-1]=1; w=(w+1)%200005;}
}
if(x+1<=n+m&&a[x+1]>a[x]+1)
{a[x+1]=a[x]+1;
if(!mark[x+1]) {q[w]=x+1; mark[x+1]=1; w=(w+1)%200005;}
}
if(x<<1<=n+m&&a[x<<1]>a[x]+1)
{a[x<<1]=a[x]+1;
if(!mark[x<<1]) {q[w]=x<<1; mark[x<<1]=1; w=(w+1)%200005;}
}
mark[x]=0;
if(a[m]<inf) {printf("%d\n",a[m]); break;}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs