您的位置:首页 > 其它

SDUT 1500 Message Flood(字典树 && 模板)

2014-08-02 19:50 381 查看


Message Flood


题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to
keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long
name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how
many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated.
Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.


输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will
be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.


输出

For each case, print one integer in one line which indicates the number of left friends he must send.


示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0



示例输出

3


字典树的模板。。。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define N 26
struct node
{
    int f;
    struct node *next 
;
};
struct node  *build ( )
{
    struct node *p ;
    int i;
    p=(struct node *)malloc(sizeof (struct node ));
    for (i=0; i<N; i++)
    {
        p->next[i]=NULL;
    }
    p->f=0;
    return p;
}
void charu (struct node *p,char *s)
{
    int i,len,ans;
//    struct node *p=t;
    len = strlen (s);
    for (i=0; i<len; i++)
    {
        if (s[i]>='A' && s[i]<='Z')
            ans=s[i]-'A';
        else ans=s[i]-'a';
        if (p->next[ans]==NULL)
            p->next[ans] =build ( );
        p=p->next [ans];
    }
    p->f=1;
}
int findd (struct node *t,char *s)
{
    int i,len,ans;
//    struct node *p=t;
    len=strlen (s);
    for (i=0; i<len ; i++)
    {
        if (s[i]>='A' && s[i]<='Z')
            ans=s[i]-'A';
        else ans=s[i]-'a';
        if (t->next[ans]==NULL)  return 0;
        t=t->next[ans];

    }
    if (t->f==1)
    {
        t->f=0;
        return 1;
    }
    else
        return 0;
}
void del (struct node *t)
{
    int i;
    for (i=0;i<N;i++)
    {
        if (t->next[i]!=NULL)
        {
            del(t->next [i]);
        }
    }
    free(t);
}
int main ()
{
    int n,m;
    char ptr[20000][100],ptrr[100];
    struct node *tree;
    while (~scanf ("%d",&n) && n)
    {
        int t=n,i;
        scanf ("%d",&m);
        tree=build ();
        for (i=0;i<n;i++)
        {
            scanf ("%s",ptr[i]);
        }

        int count =0;
        while (m--)
        {
            scanf ("%s",ptrr);
             charu (tree,ptrr);

        }
        for (i=0;i<n;i++)
        {
             count += findd (tree,ptr[i]);
        }
        printf ("%d\n",t-count);
        del (tree);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: