您的位置:首页 > 其它

Fast Food - UVa 662 dp

2014-08-02 18:49 387 查看


Fast Food

The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurent and supplying several of the restaurants
with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers

(these
are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number

will
be given, the number of depots to be built.
The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping
costs, the total distance sum, defined as



must be as small as possible.
Write a program that computes the positions of the k depots, such that the total distance sum is minimized.

Input

The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will
satisfy

,

,

.
Following this will n lines containing one integer each, giving the positions di of
the restaurants, ordered increasingly.
The input file will end with a case starting with n = k = 0. This case should not be processed.

Output

For each chain, first output the number of the chain. Then output an optimal placement of the depots as follows: for each depot output a line containing its position and the range of restaurants it serves. If
there is more than one optimal solution, output any of them. After the depot descriptions output a line containing the total distance sum, as defined in the problem text.

Output a blank line after each test case.

Sample Input

6 3
5
6
12
19
20
27
0 0


Sample Output

Chain 1
Depot 1 at restaurant 2 serves restaurants 1 to 3
Depot 2 at restaurant 4 serves restaurants 4 to 5
Depot 3 at restaurant 6 serves restaurant 6
Total distance sum = 8


题意:在n个餐厅里设立m个为仓库,使得每个餐厅到最近的仓库的距离和最小。

思路:先求出sum[i][j]为i到j的餐厅之间如果设立一个仓库的距离最小和,sum[i][j]=sum[i][j-1]+num[j]-num[(i+j)/2];因为仓库设在中间肯定是距离最小的,偶数个的话,中间的两个是一样的。然后遍历k使得dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);表示到i个餐厅设立j个仓库的最短距离。然后输出路径。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int sum[210][210],dp[210][40],num[210],pos[40];
int main()
{ int t=0,n,m,k,i,j,l,r;
  while(~scanf("%d%d",&n,&m) && n+m)
  { for(i=1;i<=n;i++)
     scanf("%d",&num[i]);
    for(i=1;i<=n;i++)
     for(j=i+1;j<=n;j++)
      sum[i][j]=sum[i][j-1]+num[j]-num[(i+j)/2];
    for(i=1;i<=n;i++)
    { dp[i][1]=sum[1][i];
      for(j=2;j<=m;j++)
       { dp[i][j]=dp[1][j-1]+sum[2][i];
         for(k=2;k<i;k++)
          dp[i][j]=min(dp[i][j],dp[k][j-1]+sum[k+1][i]);
       }
    }
    l=n;
    for(j=m;j>=1;j--)
    { for(k=0;k<=l;k++)
       if(dp[l][j]==dp[k][j-1]+sum[k+1][l])
       { pos[j]=k+1;
         l=k;
         break;
       }
    }
    pos[m+1]=n+1;
    printf("Chain %d\n",++t);
    for(i=1;i<=m;i++)
    { l=pos[i];r=pos[i+1]-1;
      if(r-l>0)
       printf("Depot %d at restaurant %d serves restaurants %d to %d\n",i,(l+r)/2,l,r);
      else
       printf("Depot %d at restaurant %d serves restaurant %d\n",i,l,l);
    }
    printf("Total distance sum = %d\n\n",dp
[m]);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: