您的位置:首页 > 其它

FZU-Problem 2146 Easy Game

2014-08-02 10:51 330 查看

Problem 2146 Easy Game

Accept: 429 Submit: 595

Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on a string S. Now they would like to count the length of this string. But as both Fat brother and Maze are programmers, they can recognize only two numbers 0 and 1. So instead of judging the
length of this string, they decide to judge weather this number is even.



Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains a line describe the string S in the treasure map. Not that S only contains lower case letters.

1 <= T <= 100, the length of the string is less than 10086



Output

For each case, output the case number first, and then output “Odd” if the length of S is odd, otherwise just output “Even”.



Sample Input

4

well

thisisthesimplest

problem

inthiscontest



Sample Output

Case 1: Even

Case 2: Odd

Case 3: Odd

Case 4: Odd

//水

#include<cstdio>
#include<cstring>
char map[10087];
int main()
{
int t,k;
scanf("%d",&t);
getchar();
for(k=1;k<=t;k++)
{
gets(map);
if(strlen(map)%2==0) printf("Case %d: Even\n",k);
else printf("Case %d: Odd\n",k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: