您的位置:首页 > 其它

HDU1258 Sum It Up 【DFS】+【判重】

2014-08-02 09:25 429 查看

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3944    Accepted Submission(s): 2026

[align=left]Problem Description[/align]
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2,
and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

 

[align=left]Input[/align]
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise,
t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order,
and there may be repetitions.

 

[align=left]Output[/align]
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order.
A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums
with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

 

[align=left]Sample Input[/align]

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

 

[align=left]Sample Output[/align]

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

判重的方法很巧妙。

#include <stdio.h>

int arr[12], vis[12];
int t, n, ok;

void PRINT(int id)
{
for(int i = 0; i < id; ++i)
if(i != id - 1) printf("%d+", vis[i]);
else printf("%d\n", vis[i]);
ok = 1;
}

void DFS(int index, int id, int sum)
{
if(sum >= t){
if(sum == t) PRINT(id);
return;
}
for(int j = index; j < n; ++j){
if(j == index || arr[j] != arr[j-1]){
vis[id] = arr[j];
DFS(j+1, id+1, sum+arr[j]);
}
}
}

int main()
{
while(scanf("%d%d", &t, &n), n){
for(int i = 0; i < n; ++i)
scanf("%d", arr + i);
printf("Sums of %d:\n", t);
ok = 0; DFS(0, 0, 0);
if(!ok) printf("NONE\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU1258