您的位置:首页 > 大数据 > 人工智能

uva442(Matrix Chain Multiplication)—线性表

2014-08-02 08:32 281 查看


 Matrix Chain Multiplication 
Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the
number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n ( 

 ), representing
the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"


Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print
one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))


Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

模拟矩阵链乘

#include<stdio.h>
#include<string.h>
int row[30],column[30];
typedef struct{
int row1;
int column1;
char c;
}stack;
stack myStack[30];
int top=-1;
int main(){
int n;
scanf("%d",&n);
char c;
while(n--){
getchar();
scanf("%c",&c);
getchar();
scanf("%d%d",&row[c-'A'],&column[c-'A']);
}
getchar();
char t;
int flag=0;
int sum=0;
while((t=getchar())!=EOF){
if(t=='\n'){
if(flag==2)
printf("0\n");
else if(flag==1){
printf("error\n");
}
else
printf("%d\n",sum);
flag=0;
top=-1;
sum=0;
}
else{
if(top==-1){
if(t!='(')
flag=2;
else{
top++;
myStack[top].column1=0;
myStack[top].row1=0;
myStack[top].c=t;
}
}
else{
if(t=='('){
top++;
myStack[top].column1=0;
myStack[top].row1=0;
myStack[top].c=t;
}
else if(t==')'){
int te=myStack[top].column1;
int temp=myStack[top].column1;
int ter=myStack[top].row1;
int tec=myStack[top].column1;
top--;
while(myStack[top].c!='('){
if(ter==myStack[top].column1){
temp=temp*myStack[top].column1;
ter=myStack[top].row1;
tec=myStack[top].column1;
}
else
flag=1;
top--;
}
myStack[top].c='[';
myStack[top].row1=ter;
myStack[top].column1=te;
temp=temp*ter;
sum=sum+temp;
}
else{
top++;
myStack[top].column1=column[t-'A'];
myStack[top].row1=row[t-'A'];
myStack[top].c=t;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva 线性表