您的位置:首页 > 产品设计 > UI/UE

uva133(The Dole Queue)—线性表

2014-08-02 08:23 387 查看



 The Dole Queue 
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing
inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts
from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person
and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three
numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0


Sample output


 4 

 8, 

 9 

 5, 

 3 

 1, 

 2 

 6, 

 10, 

 7
where 

 represents a space.
#include<stdio.h>
#include<string.h>
#define MAX 100
int sqlist[MAX];
int mark[MAX];
void init(int n){
int i;
for(i=0;i<n;i++){
sqlist[i]=i;
}
memset(mark,0,sizeof(mark));
}
int do_select(int n,int k,int m,int& right,int& left){
int countr=0,countl=0;
while(countr<k){
right=(right+1)%n;
if(mark[right]==0){
countr++;
}
}
while(countl<m){
left=(left-1+n)%n;
if(mark[left]==0){
countl++;
}
}
mark[right]=mark[left]=1;
if(right!=left)
return 2;
else
return 1;
}
int main(){
int n,k,m;
while(scanf("%d%d%d",&n,&k,&m)!=EOF){
if(n==0&&k==0&&m==0)
break;
init(n);
int temp=n;
int clo=n,coclo=-1;
while(n!=0){
if(do_select(temp,k,m,coclo,clo)==2){
printf("%3d%3d",sqlist[coclo]+1,sqlist[clo]+1);
n=n-2;
}
else{
printf("%3d",sqlist[coclo]+1);
n=n-1;
}
if(n!=0){
printf(",");
}
}
printf("\n");
}
return 0;
}

 The Dole Queue 
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing
inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts
from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person
and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three
numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0


Sample output


 4 

 8, 

 9 

 5, 

 3 

 1, 

 2 

 6, 

 10, 

 7
where 

 represents a space.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva