您的位置:首页 > 其它

zoj 1005 Jugs

2014-08-01 22:22 288 查看
Jugs

Time Limit: 2 Seconds Memory Limit: 65536 KB Special Judge

In the movie "Die Hard 3", Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon
jug with exactly 4 gallons. This problem generalizes that puzzle.
You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from
one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and
3 gallons in A.
A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly
N gallons in jug B. The possible steps are
fill A

fill B

empty A

empty B

pour A B

pour B A

success
where "pour A B" means "pour the contents of jug A into jug B", and "success" means that the goal has been accomplished.
You may assume that the input you are given does have a solution.
Input
Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the
capacities of jugs A and B, and N is the goal. You can assume 0 < Ca <= Cb and N <= Cb <=1000 and that A and B are relatively prime to one another.
Output
Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water.
The last line of output for each puzzle should be the line "success". Output lines start in column 1 and there should be no empty lines nor any trailing spaces.

Sample Input

3 5 4
5 7 3

Sample Output

fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success


这道题答案不唯一,不一定要和测试样例一样的。
(1)

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int ca,cb,N;
int b,bnow;
while (cin>>ca>>cb>>N)
{
b=bnow=0;
while (b !=N)
{
for (int i=0; i<=(cb-b)/ca; i++)   //把b水壶灌满
{
cout<<"fill A"<<endl;
cout<<"pour A B"<<endl;
bnow=b+ca*(i+1);              //b水壶现在的容量
if(bnow==N)
{
break;
}
}
if (bnow==N)
{
break;
}
cout<<"empty B"<<endl;
int a=ca-(cb-b)%ca;              //最后一次b水壶时,a水壶剩下的容量
cout<<"pour A B"<<endl;
b=a;                             //a水壶剩余的水量倒给b
if(b==N)
{
break;
}
}
cout<<"success"<<endl;
}
}


(2)

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int ca,cb,bnow,n;
while (cin>>ca>>cb>>n)
{
bnow=0;
while (bnow != n)
{
cout<<"fill A"<<endl;
cout<<"pour A B"<<endl;
bnow+=ca;                   // 向水壶b倒水
if(bnow>=cb)
{
if(bnow==cb && cb==n)   //处理特殊情况
{

}
else
{
bnow-=cb;
cout<<"empty B"<<endl;
cout<<"pour A B"<<endl;
}

}
if(bnow==n)
{
break;
}
}
cout<<"success"<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: