您的位置:首页 > 其它

HDOJ 2680 Choose the best route(最短路,dijkstra)

2014-08-01 20:27 381 查看


Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6681    Accepted Submission(s): 2215


Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take.
You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

 

Input

There are several test cases. 

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

 

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

 

Sample Output

1
-1

 
定点为1到n,且路径为单向的(这里我被坑了)
自己多加个0号定点进去,然后用dijkstra算法就可以A了

#include<stdio.h>

#include<iostream>

#include<string.h>

#include<math.h>

#include<queue>

#include<stack>

#include<algorithm>

#include<set>

using namespace std;

const int N=1010;

const int inf=10000000;

int g

;

int vis
;

int dis
;

int n,m;

void dijkstra()

{

    memset(vis,0,sizeof(vis));

    for(int i=1;i<=n;i++)

        dis[i]=g[0][i];

    for(int i=1;i<=n;i++)

    {

        int min_value=inf;

        int flag=0;

        for(int j=1;j<=n;j++)

        {

            if(!vis[j]&&dis[j]<min_value)

            {

                min_value=dis[j];

                flag=j;

            }

        }

            vis[flag]=1;

            for(int j=1;j<=n;j++)

                if(!vis[j]&&dis[j]>dis[flag]+g[flag][j])

                dis[j]=dis[flag]+g[flag][j];

    }

}

int main()

{

    int s;

    while(scanf("%d%d%d",&n,&m,&s)!=EOF)

    {

        for(int i=0;i<=n;i++)

            for(int j=0;j<=n;j++)

            g[i][j]=i==j?0:inf;

        for(int i=0;i<m;i++)

        {

            int a,b,c;

            scanf("%d%d%d",&a,&b,&c);

            if(c<g[a][b])

                g[a][b]=c;

        }

        int q;

        scanf("%d",&q);

        while(q--)

        {

            int t;

            scanf("%d",&t);

            g[0][t]=0;

        }

        dijkstra();

        if(dis[s]==inf)

            printf("-1\n");

        else

            printf("%d\n",dis[s]);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: