您的位置:首页 > 其它

poj 2309 BST(水)

2014-08-01 14:55 381 查看
BST

点击打开题目链接

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8546Accepted: 5185
Description
Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node
until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries.



Input
In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output
There are N lines in total, the i-th of which contains the answer for the i-th query.
Sample Input
2
8
10

Sample Output
1 15
9 11

Source
满二叉树搜索树,此题中搜索树只有最后一层是奇数,每个节点一下有k层,最小值在最左边,最大值在最右边;‘
#include<stdio.h>
int lowbit(int x)
{
    return x&(-x);
}
int main()
{
    int t,minnum,maxnum,x;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d",&x);
            minnum=x-lowbit(x)+1;//minnum=x-2^k+1;
            maxnum=x+lowbit(x)-1;//maxnum=x+2^k-1;
            printf("%d %d\n",minnum,maxnum);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: