您的位置:首页 > 其它

【PAT (Advanced Level)】1031. Hello World for U (20)

2014-08-01 14:49 453 查看


1031. Hello World for U (20)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1characters, then left to right along the bottom line with n2 characters, and
finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 =
max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!

Sample Output:
h   !
e   d
l   l
lowor


这个题目就是要把一个字符串按照“U”型放入一个数组,然后输出这个数组就可以了,主要要注意的就是数组中“U”型拐角的计算

代码如下:

/************************************
This is a test program for anything
Enjoy IT!
************************************/

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <set>
#include <fstream>
#include <string>
#include <cmath>
using namespace std;

int main()
{
/*ifstream cin;
cin.open("in.txt");
ofstream cout;
cout.open("out.txt");*/
//////////////////////////////////////////////////////////////////////////
// TO DO Whatever You WANT!
string s;
while (cin >> s)
{
int n1, n2, n3;
n1 = n3 = (s.length() + 2) / 3;
n2 = s.length() + 2 - n1 - n3; // 定义n1, n2, n3大小
char **p = new char*[n1];
for (int i = 0; i < n1; p[i++] = new char[n2]); // 构造二维数组
for (int i = 0; i < n1; i++)
{
for (int j = 0; j < n2; p[i][j++] = 32); // 初始化二维数组
9cf1
ASCII32是空格
}

for (int i = 0; i < n1; i++) // 填入n1
{
p[i][0] = s[i];
}
for (int i = 1; i < n2; i++) // 填入n2
{
p[n1 - 1][i] = s[n1 + i - 1];
}
for (int i = 1; i < n3; i++) // 填入n3
{
p[n3 - i - 1][n2 - 1] = s[n1 + n2 + i - 2];
}

for (int i = 0; i < n1; i++) // 输出数组
{
for (int j = 0; j < n2; j++)
{
cout << p[i][j];
}
cout << endl;
}
}
//////////////////////////////////////////////////////////////////////////
// system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT