您的位置:首页 > 其它

POJ 1004 Financial Management

2014-08-01 07:32 302 查看
Description

Larry graduated this year and finally has ajob. He's making a lot of money, but somehow never seems to have enough. Larryhas decided that he needs to grab hold of his financial portfolio and solve
hisfinancing problems. The first step is to figure out what's been going on withhis money. Larry has his bank account statements and wants to see how much moneyhe has. Help Larry by writing a program to take his closing balance from eachof the past twelve
months and calculate his average account balance.


Input

The input will be twelve lines. Each linewill contain the closing balance of his bank account for a particular month.Each number will be positive and displayed to the penny. No dollar sign will beincluded.

Output

The output will be a single number, theaverage (mean) of the closing balances for the twelve months. It will berounded to the nearest penny, preceded immediately by a dollar sign, andfollowed by the
end-of-line. There will be no other spaces or characters in theoutput.


Sample Input

100.00

489.12

12454.12

1234.10

823.05

109.20

5.27

1542.25

839.18

83.99

1295.01

1.75

Sample Output

$1581.42

解题思路:本题就是输入12个月的工资,输出12个月的平均工资,要求输出将它舍入到最近的便士。

一开始,我用的是C语言,输出保留两位小数,但是WA,最后改成用C++输出就没问题了。

代码如下:

#include<iostream>
using namespace std;
int main()
{
int i;
double a[12],sum=0.0;
for(i=0;i<12;i++)
{
cin>>a[i];
sum+=a[i];
}
cout<<"$"<<sum/12<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: