您的位置:首页 > 其它

老BOJ 08 Rightmost Digit

2014-08-01 06:17 232 查看
Rightmost Digit
Accept:540 Submit:1841
Time Limit:1000MS Memory Limit:65536KB
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

快速幂取模-求出n^n的最右位数

#include<cstdio>
#include<iostream>
int modexp(int a,int b,int n){
int ret=1,tmp=a%n;
while(b){
if(b&1){ret*=tmp;ret%=n;}
tmp*=tmp;
tmp%=n;
b>>=1;
}
return ret;
}
int main(){
int t,a;
for(scanf("%d",&t);t--;){
scanf("%d",&a);
printf("%d\n",modexp(a,a,10));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: