您的位置:首页 > 移动开发

hdu 4906 Our happy ending

2014-08-01 01:00 281 查看

Our happy ending

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 157 Accepted Submission(s): 39


[align=left]Problem Description[/align]
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

Y*wan still remember the day he first meets the devil. Now everything is done and the devil is gone. Y*wan feel very sad and suicide.

You feel guilty after killing so many loli, so you suicide too.

Nobody survive in this silly story, but there is still some hope, because this is just a silly background story during one programming contest!

And the last problem is:

Given a sequence a_1,a_2,...,a_n, if we can take some of them(each a_i can only be used once), and they sum to k, then we say this sequence is a good sequence.

How many good sequence are there? Given that each a_i is an integer and 0<= a_i <= L.

You should output the result modulo 10^9+7.

[align=left]Input[/align]
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains 3 integers n, k, L.

T<=20, n,k<=20 , 0<=L<=10^9.

[align=left]Output[/align]
For each cases, output the answer in a single line.

[align=left]Sample Input[/align]

1
2 2 2

[align=left]Sample Output[/align]

6

[align=left]Author[/align]
WJMZBMR

[align=left]Source[/align]
2014 Multi-University Training Contest 4

说是送分题,真是忧伤,,,,

送分应该就是送罚时把==

算是状态dp吧
dp[i] 表示 i 状态下的方案数。

i 化为二进制时 ,第一位为 1 表示有和为1 的存在,0表示没有,第二位为 1 时表示有和为 2的存在

第三位为 1 时表示有和为 3的存在...
转移:sta = i|(1<<(k-1))|(i<<j&m) ;
表示 i 的状态转移到了 sta状态
假如当前的状态 为 3 二进制就是 11,表示有和为 1,2的存在,
如果加上 3 ,那么 3 的状态就可以达到,也就是 |(1<<(3-1))
还有3可以和1,2加,也就是 原来的加上 3 ,也就是左移 3 位 |(i<<j)&m
因为大于 k的和我们是不在意的,所以最大的状态就是 (1<<k)-1 ;

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#define maxn 100010
#define mod 1000000007
#define LL long long
using namespace std;
int dp[(1<<20)+10] ;
int main()
{
int i ,n,m,k,j ;
int T ,L ;
cin >> T ;
while( T-- )
{
scanf("%d%d%d",&n,&k,&L) ;
memset(dp,0,sizeof(dp)) ;
dp[0]=1 ;
m = (1<<k)-1 ;
int tot = 0 ;
if(L > k)
{
tot = L-k ;
L = k ;
}
while(n--)
{
for( i = m ; i >= 0 ;i--)
{
if(dp[i]==0) continue ;
j = dp[i] ;
LL tmp = (LL)tot*dp[i]%mod ;
for( int u = 1 ; u <= L ;u++)
{
int sta = (i|(1<<(u-1))|((i<<u)&m)) ;
dp[sta] += j ;
dp[sta] %= mod;
}
dp[i] = (dp[i]+tmp)%mod ;
}
}
LL ans = 0 ;
for( i = 0 ; i <= m ;i++)
if((i>>(k-1))&1)
{
ans = (ans+dp[i])%mod ;
}
cout << ans << endl;
}
return 0 ;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: