您的位置:首页 > 其它

poj 2499 Binary Tree(水题)

2014-07-31 20:26 351 查看
Binary Tree

点击打开题目链接

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6023Accepted: 2794
Description
Background

Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:

The root contains the pair (1, 1).

If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem

Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right
child?
Input
The first line contains the number of scenarios.

Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent

a node (i, j). You can assume that this is a valid node in the binary tree described above.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how
often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.
Sample Input
3
42 1
3 4
17 73

Sample Output
Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

Source

碰到这样的水题不太容易啊,保存下来O(∩_∩)O哈!;
题目就是给出一些坐标问,从(1,1)点走到给出的坐标(x,y)要走多少次左孩子,多少次右孩子;
因为题目已规定左孩子和右孩子的坐标,左孩子都是x>y,右孩子都是y>x;判断出x,y的大小判断走到(1,y)或者(x,1)的次数(为什么?因为最终肯定要回到边上);
用除法代替减法;
代码:
#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int t,num,a,b,cl,cr;
    while(~scanf("%d",&t))
    {
        for(num=1; num<=t; num++)
        {
            cl=0;
            cr=0;
            scanf("%d%d",&a,&b);
            while(a>1&&b>1)
            {
                if(a>b)
                {
                    cl+=(a-1)/b;
                    a-=(a-1)/b*b;
                }
                else
                {
                    cr+=(b-1)/a;
                    b-=(b-1)/a*a;
                }
            }
            if(a>1)
            {
                cl+=a-1;
            }
            else
            {
                cr+=b-1;
            }
            printf("Scenario #%d:\n",num);
            printf("%d %d\n\n",cl,cr);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: