您的位置:首页 > 其它

hd 1018 Big Number 正整数a的位数(int)log10(a)+1;n的阶乘的位数

2014-07-31 18:06 369 查看

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25557    Accepted Submission(s): 11594


[align=left]Problem Description[/align]
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of
digits in the factorial of the number.

 

 

[align=left]Input[/align]
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

 

 

[align=left]Output[/align]
The output contains the number of digits in the factorial of the integers appearing in the input.

 

 

[align=left]Sample Input[/align]

2
10
20

 

 
[align=left]Sample Output[/align]

7
19

 

 

[align=left]Source[/align]
Asia 2002, Dhaka (Bengal)
 

 

[align=left]Recommend[/align]
JGShining   |   We have carefully selected several similar problems for you:  1017 1016 1071 1003 1019 
 
/****************************************************这题要求n的阶乘的位数,如果n较大时,n的阶乘必将是一个很大的数,题中说1<=n<10000000,当n=10000000时可以说n的阶乘将是一个非常巨大的数字,对于处理大数的问题,我们一般用字符串,这题当n取最大值时,就是一千万个数字相乘的积,太大了,就算保存在字符串中都有一点困难,而且一千万个数字相乘是会涉及到大数的乘法,大数的乘法是比较耗时的,就算计算出结果一般也会超时。这让我们不得不抛弃这种直接的方法。再想一下,这题是要求n的阶乘的位数,而n的阶乘是n个数的乘积,那么要是我们能把这个问题分解就好了。在这之前,我们必须要知道一个知识,任意一个正整数a的位数等于(int)log10(a)
+ 1;为什么呢?下面给大家推导一下: 对于任意一个给定的正整数a, 假设10^(x-1)<=a<10^x,那么显然a的位数为x位, 又因为 log10(10^(x-1))<=log10(a)<(log10(10^x)) 即x-1<=log10(a)<x 则(int)log10(a)=x-1, 即(int)log10(a)+1=x 即a的位数是(int)log10(a)+1我们知道了一个正整数a的位数等于(int)log10(a) + 1,现在来求n的阶乘的位数:假设A=n!=1*2*3*......*n,那么我们要求的就是(int)log10(A)+1,而:log10(A)
=log10(1*2*3*......n) (根据log10(a*b) = log10(a) + log10(b)有) =log10(1)+log10(2)+log10(3)+......+log10(n)现在我们终于找到方法,问题解决了,我们将求n的阶乘的位数分解成了求n个数对10取对数的和,并且对于其中任意一个数,都在正常的数字范围之类。总结一下:n的阶乘的位数等于 (int)(log10(1)+log10(2)+log10(3)+......+log10(n)) + 1

 

double p;for(i=1;i<=n;i++)p=0;p+=log10(i);printf("%d\n",(int)p+1);

#include<stdio.h>

#include<math.h>

int main()

{

    int t,j,n;

    double p;

    while(scanf("%d",&t)!=EOF)

    {

      while(t--)

      {

           p=0;

          scanf("%d",&n);   

          for(j=1;j<=n;j++)

          {

          p+=(log10(j));

                           }

          printf("%d\n",(int)p+1);

                }

                              }

return 0;

    }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: