您的位置:首页 > 其它

hdu 4882 ZCC Loves Codefires 2014年多校联合第二场

2014-07-31 17:49 513 查看


ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1495    Accepted Submission(s): 550


Problem Description

   Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".
It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.
But why?
Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures.
After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.
What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time.
Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).

 

Input

   The first line contains an integer N(1≤N≤10^5), the number of problem in the round.
The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.
The last line contains N integers Ki(1≤Ki≤10^4), as was described.

 

Output

   One integer L, the minimal score he will lose.

 

Sample Input

3
10 10 20
1 2 3

 

Sample Output

150

HintMemset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second.
L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150.

题意:

求Ei*Ki的和的最大值。

典型的贪心,但是输出我整错了好几遍.wa了若干遍才反应过来。



代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#define M 100100
using namespace std;
struct point{
int e;
int k;
double s;
}p[M];

bool cmp(point a,point b)
{
return a.s<b.s;
}

int main()
{
int n;
while(cin>>n)
{
for(int i=0;i<n;i++)
scanf("%d",&p[i].e);
for(int i=0;i<n;i++)
{
scanf("%d",&p[i].k);
p[i].s=(double)(p[i].e)/(double)(p[i].k);
}
sort(p,p+n,cmp);

long long ans=0,tmp=0;

for(int i=0;i<n;i++)
{
ans+=(p[i].e+tmp)*p[i].k;
tmp+=p[i].e;
}
printf("%I64d",ans);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 贪心