您的位置:首页 > 其它

POJ-1742-多重背包-Coins

2014-07-31 15:33 387 查看
Coins

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby
shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay
use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by
two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 101 2 4 2 1 12 51 4 2 10 0


Sample Output

84


题意:有面值为A1,A2,,,An的钱,数量分别为C1,C2,,,Cn,问刚好能组成1~m中的数有几个,详解点这里!

代码大致相同 .

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int dp[200000];
int m;
void cpl(int c,int w)//完全背包
{
int i;
for(i=c;i<=m;i++)
{
if(dp[i]<dp[i-c]+w)
dp[i]=dp[i-c]+w;
}
}
void one(int c,int w)//0-1背包
{
int i;
for(i=m;i>=c;i--)
{
if(dp[i]<dp[i-c]+w)
dp[i]=dp[i-c]+w;
}
}
void muty(int c,int w,int amount)//多重背包
{
int v;
if(c*amount>=m)             //相当于物体对于容量为sum/2的背包,个数无限多,所以当成完全背包处理
{
cpl(c,w);
return;
}
v=1;
while(v<=amount)        //转化成0-1背包处理,用二进制压缩进行优化
{
one(c*v,w*v);
amount-=v;
v*=2;
}
one(c*amount,amount*w);
}
int main()
{
int n,A[105],C[105],i,j,cnt;
while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
{
cnt=0;
for(i=1;i<=n;i++)
scanf("%d",&A[i]);
for(i=1;i<=n;i++)
scanf("%d",&C[i]);
memset(dp,0,sizeof(dp));
for(j=1;j<=n;j++)
{
muty(A[j],A[j],C[j]);
}
for(i=1;i<=m;i++)
{
if(dp[i]==i)
cnt++;
}
printf("%d\n",cnt);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: