您的位置:首页 > 理论基础 > 数据结构算法

HDU 1988 Cube Stacking (数据结构-并查集)

2014-07-30 11:42 447 查看
Cube Stacking

Time Limit: 2000MSMemory Limit: 30000K
Total Submissions: 18834Accepted: 6535
Case Time Limit: 1000MS
Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:

moves and counts.

* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.

* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For
count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

USACO 2004 U S Open
题目大意:


有N个立方体和N个格子,1~N编号,一开始i立方体在i号格子上,每个格子刚好1个立方体。现在m组操作,M a b表示将a号立方体所在的格子的全部立方体放在b号立方体所在的格子的全部立方体上面。C x表示询问x号立方体下面的立方体的个数。


解题思路:


在并查集的基础上,只需要知道x到父亲的距离以及父亲到底的距离就知道x到底的距离。


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn=31000;
int father[maxn],cnt[maxn],dis[maxn];

int find(int x){
if(father[x]!=x){
int tmp=father[x];
father[x]=find(father[x]);
dis[x]+=dis[tmp];
}
return father[x];
}

void combine(int x,int y){
father[x]=y;
dis[x]+=cnt[y];
cnt[y]+=cnt[x];
}

int main(){
int m;
scanf("%d",&m);
for(int i=0;i<maxn;i++){
father[i]=i;
cnt[i]=1;
dis[i]=0;
}
while(m-- >0){
char ch;
cin>>ch;
if(ch=='M'){
int a,b;
scanf("%d%d",&a,&b);
if(find(a)!=find(b)) combine(find(a),find(b));
}else{
int x;
scanf("%d",&x);
find(x);
printf("%d\n",dis[x]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: