您的位置:首页 > 其它

hdu2119Matrix (二分匹配,最小顶点覆盖)

2014-07-30 10:34 211 查看

Matrix

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1819 Accepted Submission(s): 792



Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.

The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

Sample Input
3 3 
0 0 0
1 0 1
0 1 0
0


Sample Output
2


Author
Wendell
#include<stdio.h>
#include<string.h>
int map[105][105],vist[105],match[105],m;
int find(int i)
{
    for(int j=1;j<=m;j++)
    if(!vist[j]&&map[i][j])
    {
        vist[j]=1;
        if(!match[j]||find(match[j]))
        {
            match[j]=i; return 1;
        }
    }
    return 0;
}
int main()
{
    int a,n;
    while(scanf("%d",&n)>0&&n)
    {
        scanf("%d",&m);
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&a);
            if(a) map[i][j]=1;
        }
        int ans=0;
        memset(match,0,sizeof(match));
        for(int i=1;i<=n;i++)
        {
            memset(vist,0,sizeof(vist));
            ans+=find(i);
        }
        printf("%d\n",ans);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: