您的位置:首页 > 其它

HDU 1059 Dividing 多重背包

2014-07-30 10:33 323 查看
Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could
just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so
that each of them gets the same total value.

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets
of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.



Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described
by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.



Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.



Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0




Sample Output
Collection #1:
Can't be divided.

Collection #2:
Can be divided.


题意:六个数,每个数代表相应位置上价值为i的个数,判断能否将这些弹珠均分两部分。

dp代码:
#include<stdio.h>
#include<string.h>
int dp[11200];
int main()
{
    int i,j,ans;
    int a[7];
    int t=1;
    while(scanf("%d",&a[1]))
    {
        a[1]=a[1]%10;//不明觉厉,不加会超时,大神说 十以上的数字产生的效果与%10一样
        ans=a[1];
        for(i=2; i<=6; i++)
        {
            scanf("%d",&a[i]);
            a[i]%=10;
            ans+=a[i]*i;
        }
        if(ans==0)
            break;
        printf("Collection #%d:\n",t++);
        memset(dp,0,sizeof(dp));
        for(i=1; i<=6; i++)
            for(j=1; j<=a[i]; j++)
                for(int k=ans/2; k>=i; k--)
                    if(dp[k]<dp[k-i]+i)
                        dp[k]=dp[k-i]+i;
        if(2*dp[ans/2]==ans)
            printf("Can be divided.\n\n");
        else
            printf("Can't be divided.\n\n");
    }
    return 0;
}


二:多重背包模版:

# include<stdio.h>
# include<string.h>
int w[10],n[10],f[200000],V;
void ZeroOnePack(int cost,int weight)//01背包
{
       int v;
       for(v=V;v>=cost;v--)
              if(f[v]<f[v-cost]+weight)
                     f[v]=f[v-cost]+weight;
}
void CompletePack(int cost,int weight)//完全背包
{
       int v;
       for(v=cost;v<=V;v++)
              if(f[v]<f[v-cost]+weight)
                     f[v]=f[v-cost]+weight;
}
void MultiplePack(int cost,int weight,int amount)//多重背包
{
       int k;
       if (cost*amount>=V)
       {
        CompletePack(cost,weight);
              return;
       }
       k=1;
       while(k<amount)
       {
              ZeroOnePack(k*cost,k*weight);
              amount=amount-k;
              k=k*2;
       }
       ZeroOnePack(amount*cost,amount*weight);
}
int main()
{
       int i,j,t=1,a[7],sum;
       while(scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]))
       {
              if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0&&a[5]==0&&a[6]==0)
                     break;
              sum=0;j=1;
              for(i=1;i<=6;i++)
              {
                     sum+=a[i]*i;
                     if(a[i])
                     {
                            w[j]=i;
                            n[j]=a[i];
                            j++;
                     }
              }
              printf("Collection #%d:\n",t);
              if(sum%2==1)
                     printf("Can't be divided.\n");
              else
              {
                     V=sum/2;
                     memset(f,0,sizeof(f));
                     for(i=1;i<j;i++)
                            MultiplePack(w[i],w[i],n[i]);
                     if(f[V]==V)
                            printf("Can be divided.\n");
                     else
                            printf("Can't be divided.\n");
              }
              printf("\n");
              t++;
       }
       return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: