您的位置:首页 > 其它

hdu 1036 String Matching

2014-07-29 22:48 113 查看
hdu 1036 String Matching

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 883 Accepted Submission(s): 455

Problem Description

It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:

CAPILLARY

MARSUPIAL

There is only one common letter (A). Better is the following overlay:

CAPILLARY

MARSUPIAL

with two common letters (A and R), but the best is:

CAPILLARY

MARSUPIAL

Which has three common letters (P, I and L).

The approximation measure appx(word1, word2) for two words is given by:

common letters * 2

-----------------------------

length(word1) + length(word2)

Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.



Sample Input

The input for your program will be a series of words, two per line, until the end-of-file flag of -1.

Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. For example:

CAR CART

TURKEY CHICKEN

MONEY POVERTY

ROUGH PESKY

A A

-1

The words will all be uppercase.



Sample Output

Print the value for appx() for each pair as a reduced fraction, like this:

appx(CAR,CART) = 6/7

appx(TURKEY,CHICKEN) = 4/13

appx(MONEY,POVERTY) = 1/3

appx(ROUGH,PESKY) = 0

appx(A,A) = 1

/*题解:

理解题意,假设一个字符串不动,将另一字符串左移右移,找出相同字符最多的字符数。

注意:此题不是求相同的最长子串

*/

#include<cstdio>

#include<cstring>

int gcd(int a,int b)

{

return !b?a:gcd(b,a%b);

}

int s[1010];

void output(char *a,char *b)

{

int len1=strlen(a),len2=strlen(b),i,j,r,sum,s[1010];

memset(s,0,sizeof(s));

r=len1>len2?len1:len2;

for(j=0; j<r; j++)

{

for(i=0; i+j<r; i++)

if(a[j+i]==b[i])

s[j]+=2; //假设a不动将b右移进行比较



for(i=0; i+j<r; i++)

if(a[i]==b[j+i]) // 假设b不动a右移相当于a不动将b左移进行比较

s[r+j]+=2;

}

for(i=0,sum=0; i<r+j; i++)

{

if(sum<s[i])

sum=s[i]; //找出相同字符最多的

}

printf("appx(%s,%s) = ",a,b);

if(len1+len2==sum) printf("1\n");

else if(sum==0) printf("0\n");

else

{

int t=gcd(sum,len1+len2);

printf("%d/%d\n",sum/t,(len1+len2)/t);

}

}

int main()

{

char a[1010],b[1010];

while( scanf("%s",a)&&strcmp(a,"-1") )

{

scanf("%s",b);

output(a,b);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: