您的位置:首页 > 其它

HDU 2594 Simpsons’ Hidden Talents (字符串-KMP)

2014-07-29 20:41 405 查看


Simpsons’ Hidden Talents

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie


Sample Output

0
rie 3


Source

HDU 2010-05 Programming Contest

题目大意:


给你字符串s1和s2,问你s1的前缀和s2的后缀最长相同的串多长?


解题思路:


牢记KMP Next数组的含义,将s1和s2拼接在一起,next[len]也就是最终答案。


解题代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <string>
#include <sstream>
#include <cmath>
#include <algorithm>
using namespace std;

const int maxn=51000;
int next[maxn*2];
char word[maxn*2],s1[maxn],s2[maxn];

void kmp(){
int n=strlen(word);
for(int i=0;i<=n;i++) next[i]=0;
for(int i=1;i<n;i++){
int j=i;
while(j>0){
j=next[j];
if(word[j]==word[i]){
next[i+1]=j+1;
break;
}
}
}
}

int main(){
while(scanf("%s%s",s1,s2)!=EOF){
stringstream ss;
ss<<s1<<s2;
ss>>word;
kmp();
int len=strlen(word),ans=min(strlen(s1),strlen(s2));
if(next[len]<=strlen(s1) && next[len]<=strlen(s2) ){
ans=next[len];
}
if(ans==0) printf("0\n");
else{
for(int i=0;i<ans;i++) printf("%c",s1[i]);
printf(" %d\n",ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: