您的位置:首页 > 运维架构

HDU 4324 topological_sort

2014-07-29 20:27 92 查看
Triangle LOVE

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).

Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.

Sample Input

2

5

00100

10000

01001

11101

11000

5

01111

00000

01000

01100

01110

Sample Output

Case #1: Yes

Case #2: No

<span style="color:#6600cc;">/**********************************************

author   :    Grant Yuan
time     :    2014.7.29
algorithm:    topological_sort
source   :    HDU 4324
notice   :    n<3时输出为no

**********************************************/

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define MAX 2005
using namespace std;

char mat[MAX][MAX];
int num[MAX];
int n,m,ans,sum;
int lu[MAX];
int ct=1;

int main()
{   int t;
scanf("%d",&t);
while(t--){
memset(mat,0,sizeof(mat));
memset(num,0,sizeof(num));
memset(lu,0,sizeof(lu));
scanf(" %d",&n);
for(int i=0;i<n;i++)
scanf("%s",mat[i]);
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
if(mat[i][j]=='1')
num[j]++;

int i,p=n-1;
if(n<3)
printf("Case #%d: No\n",ct++);
else {while(1){
for(i=n-1;i>=0;i--)
{
if(num[i]==0)
break;
}
if(i==-1)
break;
num[i]=-1;
lu[p--]=i;
for(int j=0;j<n;j++)
{
if(mat[i][j]=='1')
num[j]--;
}
}
if(p>-1)
printf("Case #%d: Yes\n",ct++);
else
printf("Case #%d: No\n",ct++);}
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: