您的位置:首页 > 其它

九度题目1029:魔咒词典

2014-07-29 19:35 387 查看
题目1029:魔咒词典

时间限制:5 秒

内存限制:32 兆

特殊判题:否

提交:3848

解决:1111

题目描述:

    哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

    给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

输入:

    首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

    [魔咒] 对应功能

    其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。

    词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:

    每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

样例输入:

[expelliarmus] the disarming charm

[rictusempra] send a jet of silver light to hit the enemy

[tarantallegra] control the movement of one's legs

[serpensortia] shoot a snake out of the end of one's wand

[lumos] light the wand

[obliviate] the memory charm

[expecto patronum] send a Patronus to the dementors

[accio] the summoning charm

@END@

4

[lumos]

the summoning charm

[arha]

take me to the sky

样例输出:

light the wand

accio

what?

what?

来源:

2008年浙江大学计算机及软件工程研究生机试真题

 

 

 

学习使用了C++的map容器,不能c和c++再混了,这样会出现莫名其妙的编译错误(提交CE)

AC代码:

#include<stdio.h>
#include<algorithm>
#include<map>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
char a[200],str1[100],str2[100],str3[100];
map<string,string>m1;
map<string,string>::iterator iter;//迭代器
int main()
{
int i,j,n,x,y,z;
gets(a);
while(a[0]!='@')
{
n=strlen(a);
x=0;y=0;z=0;
for(i=0;i<n;i++)
{
if(a[i]!='['&&a[i]!=']')
str3[z++]=a[i];
if(a[i]==']')
{
str1[x++]=a[i];
i+=2;
break;
}
str1[x++]=a[i];
}
for(;i<n;i++)
{
str2[y++]=a[i];
}
m1.insert(pair<string,string>(str1,str2));
m1.insert(pair<string,string>(str2,str3));
memset(str1,0,sizeof(str1));
memset(str2,0,sizeof(str2));
memset(str3,0,sizeof(str3));
memset(a,0,sizeof(a));
gets(a);
}
scanf("%d",&n);
getchar();
while(n--)
{
memset(a,0,sizeof(a));
gets(a);
iter=m1.find(a);
if(iter==m1.end())
cout<<"what?\n";
else cout<<iter->second<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: