您的位置:首页 > 其它

POJ 1988 Cube Stacking

2014-07-29 19:34 218 查看
Cube Stacking

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 18820 Accepted: 6530
Case Time Limit: 1000MS
Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 

moves and counts. 

* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 

* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For
count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output
1
0
2


#include <iostream>
#include <cstring>
using namespace std;
const int maxn=100005;
int set[maxn];//set[k]为k所在栈的最底层元素
int cnt[maxn];//cnt[k]为k...set[k]的元素个数
int top[maxn];//top[k]为k所在栈的顶层元素
int main()
{
int set_find(int x);
void set_join(int x,int y);

int p;//操作的次数
cin>>p;

///////初始化/////////////
memset(set,-1,sizeof(set));
memset(cnt,0,sizeof(cnt));
int i;
for(i=0;i<maxn;i++)
top[i]=i;//初始化top[],所有栈的栈顶元素为这个元素本身

while(p--)//控制输入次数
{
char s;//操作控制字母
cin>>s;

if(s=='M')
{
int x,y;
cin>>x>>y;
set_join(x,y);//将包含元素x的元素移到包含元素y的栈顶
}
if(s=='C')
{
int x;//要求计算以x为栈顶元素的元素个数
cin>>x;
set_find(x);//计算包含x的栈中在x下的元素个数
cout<<cnt[x]<<endl;
}
}
return 0;
}

//////////计算包含x的栈中在x下的元素个数////////
int set_find(int x)
{
if(set[x]<0) //x下面没有其他元素
return x;

if(set[set[x]]>=0)//若set[x]下面还有元素,则调整x所在栈最下面的元素
{
int fa=set[x];//设fa为p的栈底元素
set[x]=set_find(set[x]);//若set[x]下面还有元素,则调整x的栈底元素
cnt[x]=cnt[fa]+cnt[x];//累加从fa到set[x]的的元素个数
}
return set[x];
}

/////////将x所在的栈移到y所在栈的栈顶////////////
void set_join(int x,int y)
{
x=set_find(x);//x为x所在栈的栈底元素
y=set_find(y);//y为y所在栈的栈底元素

set[x]=y;//将x栈移到y的栈顶,更新x的栈底元素
set_find(top[y]);//刷新y所在栈原先的栈顶元素到y之间的元素个数
cnt[x]=cnt[top[y]]+1;
top[y]=top[x];//更新y的栈顶元素为x的栈顶元素
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: