您的位置:首页 > 其它

hdu 1031 Design T-Shirt

2014-07-29 19:33 148 查看

Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5745 Accepted Submission(s): 2659

Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible
to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each
element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.



Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number
of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.



Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions,
you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.



Sample Input
3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2




Sample Output
6 5 3 1
2 1



排序:
<span style="font-size:18px;">#include<stdio.h>
#include<iostream>
#include<algorithm >
using namespace std;
double a[101][101];
struct node
{
	double x;
	int y;
}p[101];

bool cmp1(node k1,node k2)
{
	return (k1.x>k2.x);
}

bool cmp2(node k1,node k2)
{
	return (k1.y>k2.y);
}

int main ()
{
	int n,m,k;
	int i,j;
	double sum;
	while(scanf("%d%d%d",&n,&m,&k)!=EOF)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%lf",&a[i][j]);
		
			for(j=1;j<=m;j++)
			{ 
				sum=0;
				for(i=1;i<=n;i++)
					sum+=a[i][j]; //求每一列之和
				p[j].x=sum;
				p[j].y=j;
			}
			sort(p+1,p+m+1,cmp1);   // 按和排序
			sort(p+1,p+k+1,cmp2);   // 按下标排序
			for(i=1;i<=k;i++)
			{
				if(i!=k)  printf("%d ",p[i].y);
				else printf("%d\n",p[i].y);
			}
	}
	return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: