您的位置:首页 > 其它

The Triangle (poj 1163)

2014-07-29 17:20 302 查看
The Triangle

Time Limit: 1000MSMemory Limit: 10000K
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1
but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30


//59

#include <stdio.h>
#include <string.h>

#define N 105
#define Max(a,b) ((a)>(b)?(a):(b))

int d

;
int n;

int input(){
int i,j;
memset(d,0,sizeof(d));
for(i=1;i<=n;i++){
for(j=1;j<=i;j++){
scanf("%d",&d[i][j]);
}
}
}

int DP(){
int i,j;

for(i=2;i<=n;i++){
for(j=1;j<=i;j++){
d[i][j]=Max(d[i-1][j]+d[i][j],d[i-1][j-1]+d[i][j]);
}
}

for(i=1;i<=n;i++){
if(d[0][0]<d
[i])	d[0][0]=d
[i];
}

return d[0][0];
}

int main(){
while(scanf("%d",&n)==1){
input();
printf("%d\n",DP());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: