您的位置:首页 > 其它

An easy problem hdoj 2055

2014-07-29 16:15 113 查看
An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13607    Accepted Submission(s): 9186

Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

 

Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

 

Output

for each case, you should the result of y+f(x) on a line.

 

Sample Input

6

R 1

P 2

G 3

r 1

p 2

g 3

 

Sample Output

19

18

10

-17

-14

-4

 

Author

8600

 

Source

校庆杯Warm Up 

*/

#include<cstdio>

#include<string.h>

#include<stdlib.h>

int main()

{
int T;
scanf("%d",&T);
getchar();//1
while(T--)
{
char c;
int n;
c=getchar();
scanf("%d",&n);
//scanf("%c%d",&c,&n); 或是此种输入格式;
int sum;
  if(c>='A'&&c<='Z')
    sum=(c-'A'+1)+n;
    else 
      sum=('a'-c-1)+n;
      printf("%d\n",sum);
  getchar();
//2
}
return 0;

}

这是给初学者的一个很好地题,我感觉应该把它贴出来:

1、它对我们的输入输出格式有了很好地考察;

2、去掉其中1或2,我们可以看看程序运行的情况。

3、这是以后做字符串类题的很好地引导。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: