您的位置:首页 > 其它

hdu 1020 Encoding

2014-07-28 23:43 387 查看
Encoding(字符串)

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 2 Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2

ABC

ABBCCC

Sample Output

ABC

A2B3C

/* 题解:

简单的字符串水题,输出字符串后,边判断边输出

*/

#include<cstdio>

#include<cstring>

int main(){

int n;

scanf("%d",&n);

while(n--)

{

int i,count=1;

char a[10100];

scanf("%s",a);

for(i=0; i<strlen(a); i++)

{

if(a[i]==a[i+1])

count++;

if(a[i]!=a[i+1]&&count==1)

{

printf("%c",a[i]);

}

if(a[i]!=a[i+1]&&count!=1)

{

printf("%d%c",count,a[i]);

count=1;

}

}

printf("\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: