您的位置:首页 > 其它

CD - UVa 624 01背包记录路径

2014-07-28 22:51 465 查看


CD

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to
choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20
no track is longer than N minutes
tracks do not repeat
length of each track is expressed as an integer number
N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input

Any number of lines. Each one contains value N, (after space) number of tracks and durations of
the tracks. For example from first line in sample data: N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one
4 minutes

Output

Set of tracks (and durations) which are the correct solutions and string ``sum:" and sum of duration times.

Sample Input

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2


Sample Output

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45


题意:01背包记录路径。

思路:用pos[]代表某个位置是第几个,pre[]代表它的前一个是第几个。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int num[1010],dp[100010],pos[100010],pre[100010],ans[100010];
int main()
{ int m,n,i,j,k,p,sum;
  while(~scanf("%d",&m))
  { scanf("%d",&n);
    for(i=1;i<=n;i++)
     scanf("%d",&num[i]);
    memset(dp,-1,sizeof(dp));
    dp[0]=1;
    for(i=1;i<=n;i++)
     for(j=m;j>=num[i];j--)
      if(dp[j-num[i]]>=0 && dp[j]==-1)
      { dp[j]=1;
        pos[j]=i;
        pre[j]=j-num[i];
      }
    for(p=m;p>=0;p--)
     if(dp[p]>0)
      break;
    sum=p;
    k=0;
    while(p)
    { ans[++k]=pos[p];
      p=pre[p];
    }
    for(i=k;i>=1;i--)
     printf("%d ",num[ans[i]]);
    printf("sum:%d\n",sum);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: