您的位置:首页 > 其它

hdu 1060 Leftmost Digit

2014-07-28 21:23 393 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12980 Accepted Submission(s): 4971

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2

3

4

Sample Output

2

2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.

In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

//思路:n^n可以简化为a*10^x

// n^n=a*10^x 同时左右取对数 则n*lgn=lga+x 对于a,是0<a<1的,而x是整数

// 则lga=n*lgn-x; a=10^(n*lgn-x) x是n*lgn的整数部分,则x=(__int64)(n*lgn);

// 故此 a=a=10^(n*lgn-(__int64)(n*lgn)) ;

#include<stdio.h>
#include<math.h>
int main()
{
int n;
int m;
int a;
double i;
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
i=m*log10(m*1.0)-(__int64)(m*log10(m*1.0));
a=pow(10*1.0,i);
printf("%d\n",a);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: