您的位置:首页 > 其它

HDU - 1061 Rightmost Digit

2014-07-28 18:22 513 查看
Description

Given a positive integer N, you should output the most right digit of N^N.



Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).



Output

For each test case, you should output the rightmost digit of N^N.



Sample Input

2
3
4




Sample Output

7
6


题意:取N^N的最后一位

思路:裸的快速幂取模

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
typedef long long ll;
using namespace std;

int pow_mod(int a, int n, int m) {
	if (n == 0)
		return 1;
	if (n == 1)
		return a%m;
	int x = pow_mod(a, n/2, m);
	ll ans = (ll) x*x%m;
	if (n % 2 == 1)
		ans = ans * a % m;
	return (int)ans;
}

int main() {
	int t;
	int n;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		ll ans = pow_mod(n, n, 10);
		cout << ans << endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: