您的位置:首页 > 其它

poj 3041 Asteroids 最小覆盖点==最大二分匹配

2014-07-28 13:57 357 查看
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

* Line 1: Two integers N and K, separated by a single space.

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2

Sample Output
2

Hint
//求的是一某个点为端点的边都必须消失,这样的端点最少有几个;
//根据,最小点==最大二分匹配;
#include<stdio.h>

#include<string.h>

int Mark[550];

bool Map[550][550];

bool Flag[550];

bool Find(int x,int N)

{

int i;

for(i=1;i<=N;i++)

{

if(!Map[x][i]||Flag[i])

continue;

Flag[i]=true;

if(!Mark[i]||Find(Mark[i],N))

{

Mark[i]=x;

return true;

}

}

return false;

}

int main()

{

int N,K;

int i,x,y;

int Count;

while(scanf("%d%d",&N,&K)!=EOF)

{

Count=0;

memset(Map,false,sizeof(Map));

memset(Mark,0,sizeof(Mark));

for(i=1;i<=K;i++)

{

scanf("%d%d",&x,&y);

Map[x][y]=true;

}

for(i=1;i<=N;i++)

{

memset(Flag,false,sizeof(Flag));

if(Find(i,N))

Count++;

}

printf("%d\n",Count);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: