您的位置:首页 > 其它

hdu 2162 Add ‘em

2014-07-28 12:06 141 查看
[align=left]Problem Description[/align]
Write a program to determine the summation of several sets of integers.

[align=left]Input[/align]
The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set,
n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.

[align=left]Output[/align]
A single line of output should be generated for each set of integers. The line should have format shown below.

[align=left]Sample Input[/align]

4
-1
3
1
1
2
19
17
5
-645
952
-1488
-5456
-9342
-1


[align=left]Sample Output[/align]

Sum of #1 is 4
Sum of #2 is 36
Sum of #3 is -15979[code]#include<stdio.h>
int main()
{
int n,m;
int sum;
int a,i;
m=1;
while(scanf("%d",&n),(n>0))
{
sum=0;
for(i=0;i<n;i++)
{
scanf("%d",&a);
sum+=a;
}
printf("Sum of #%d is %d\n",m++,sum);
}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: