您的位置:首页 > 其它

HDOJ 题目2601 An easy problem(数学 水题)

2014-07-28 11:47 435 查看

An easy problem

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6196    Accepted Submission(s): 1490


[align=left]Problem Description[/align]
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..



One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.

Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

 

[align=left]Input[/align]
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).
 

[align=left]Output[/align]
For each case, output the number of ways in one line.
 

[align=left]Sample Input[/align]

2
1
3

 

[align=left]Sample Output[/align]

0
1

 

[align=left]Author[/align]
Teddy
思路:因式分解n=i*j+i+j,即(n+1)=(i+1)(j+1);
ac代码
#include<stdio.h>
#include<math.h>
int main()
{
int i,j,n,t;
scanf("%d",&t);
while(t--)
{
__int64 n,nc;
int c=0,i;
scanf("%I64d",&n);
n++;
nc=sqrt(n);
for(i=2;i<=nc;i++)
{
if(n%i==0)
c++;
}
printf("%d\n",c);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: