您的位置:首页 > 其它

Single Round Match

2014-07-28 11:37 411 查看


Problem Description

Association for Couples Match (ACM) is a non-profit organization which is engaged in helping single people to find his/her other half. As November 11th is "Singles Day", on this day, ACM invites a large group of singles to the party. People round together,
chatting with others, and matching partners. There are N gentlemen and M ladies in the party, each gentleman should only match with a lady and vice versa. To memorize the Singles Day, ACM decides to divide people into 11 groups, each group should have the
same amount of couples and no people are left without the groups. Can ACM achieve the goal?


Input

The first line of the input is a positive integer T. T is the number of test cases followed. Each test case contains two integer N and M (0<=N, M<=101000), which are the amount of gentlemen and ladies. It is worth notice that N and M are really huge. You are
suggested to input the number with string.


Output

For each test case, output “YES” if it is possible to find a way, output “NO” if not.


Sample Input

3

1 1

11 11

22 11

Sample Output

NO YES NO


题意:首先输入的第一个数代表数据的组数;

接下来的每一行都有两个数,数据很大,应该用字符储存;

首先输入的两个数都必须相等;然后都能被11整除;那么就输出YES,否则就输出NO;


# include<cstdio>
# include<iostream>
# include<cstring>
using namespace std;
int main()
{
int n;
cin>>n;
while(n--)
{
string n,m;
cin>>n>>m;
if(n!=m)
{
cout<<"NO"<<endl;
continue;
}
else
{
int r=0,i;
for(i=0;i<n.size();i++)
{
r=r*10+n[i]-'0';                   //每次取一位,-‘0’是转换类型;
r%=11;
}
if(!r)    cout<<"YES"<<endl;
else      cout<<"NO"<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: