您的位置:首页 > 其它

Bone Collector II - HDU 2639 背包第k优解

2014-07-27 12:38 411 查看


Bone Collector II

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2162 Accepted Submission(s): 1132



Problem Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum
.. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.



Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value
of each bone. The third line contain N integers representing the volume of each bone.



Output

One integer per line representing the K-th maximum of the total value (this number will be less than 231).



Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1




Sample Output

12
2
0




题意:01背包的第k优解。

思路:每次选出它的前一种状态的前k个和加上它的前k个状态,组成它的前k个状态。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int v[110],w[110],dp[1010][40],n,m,k,f[1010],num;
bool cmp(int a,int b)
{ return a>b; }
int main()
{ int t,i,j,p;
  scanf("%d",&t);
  while(t--)
  { memset(dp,0,sizeof(dp));
    scanf("%d%d%d",&n,&m,&k);
    for(i=1;i<=n;i++)
     scanf("%d",&v[i]);
    for(i=1;i<=n;i++)
     scanf("%d",&w[i]);
    for(i=1;i<=n;i++)
     for(j=m;j>=w[i];j--)
     { for(p=1;p<=k;p++)
       { f[p*2-1]=dp[j][p];
         f[p*2]=dp[j-w[i]][p]+v[i];
       }
       sort(f+1,f+1+2*k,cmp);
       dp[j][1]=f[1];num=1;
       for(p=2;p<=2*k && num<=k;p++)
        if(f[p]!=f[p-1])
         dp[j][++num]=f[p];
     }
    printf("%d\n",dp[m][k]);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: