您的位置:首页 > 其它

Lake Counting(DFS)

2014-07-27 11:28 225 查看
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.


Sample Output

3


Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

解题思路

不用visa[]标识数组,因为一个W点只会被用到一次,用过后改掉就好,相当于标记,一直搜到底,搜完一层回到上一层,(没有不满足条件的情况中途回溯)

AC代码

<pre name="code" class="html">#include <stdio.h>
#include <string.h>

int n,m,cnt;
char map[150][150];
int add[8][2] = { {1,0},{0,1},{-1,0},{0,-1},{1,1},{-1,1},{-1,-1},{1,-1}  }; 

void dfs(int i,int j)
{
    map[i][j]='#';
    for(int k=0; k<8; k++)
    {
        int x=i+add[k][0];
        int y=j+add[k][1];
        if(x<n && y<m && x>=0 && y>=0 && map[x][y] == 'W')
            dfs(x,y);
    }
}

int main()
{
    int i,j;
    scanf("%d%d",&n,&m);
    getchar();

    for(i=0; i<n; i++)
        scanf("%s",map[i]);

    cnt=0;
    for(i=0; i<n; i++)
        for(j=0; j<m; j++)
            if(map[i][j]=='W')
            {
                cnt++;
                dfs(i,j);
            }

    printf("%d\n",cnt);

    return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: